python 3.5.2 에서 pip 인스톨 안될때

로컬 개발환경 구축
python 3.5.2
Django 2.1.3
Mysql 5.7
ubuntu 18.04

현재상황
0. 2~3년 전에 만들어진 사이트 입니다.
몇일 전부터 로컬에서 개발 환경 셋팅 시도 중입니다.
1. 로컬에 python 3.5.2 설치
2. pip 인스톨도 안되고 업그레이드도 안되는 상황입니다.
3. 이런 저런 검색후 아래와 같은 메시지도 보았습니다.

지원 중단: Python 3.5는 2020년 9월 13일에 수명이 종료되었습니다.
Python 3.5는 더 이상 유지 관리되지 않으므로 Python을 업그레이드하십시오.
pip 21.0은 2021년 1월에 Python 3.5에 대한 지원을 중단합니다.
pip 21.0은 이 기능에 대한 지원을 제거합니다.

이 스크립트는 Python 3.5(최소 지원 Python 버전 3.7)에서는 작동하지 않습니다.
대신 https://bootstrap.pypa.io/pip/3.5/get-pip.py를 사용하십시오.

위 내용대로 로컬에서 실행 해도 안되는 상황 입니다?

질문
q1. 예전 버전의 파이썬은 어떻게 로컬 개발 환경 구성을 해야 하나요?
python 3.9 로된 다른 사이트는 로컬에 무난하게 개발 셋팅 한 상태 입니다.
q2. python -m pip install -r ./requesment.txt 해도 아무 변화가 없습니다?
뭐가 문제 일까요? 처음 한줄만 내용이 나오고 다음 진행이 안됩니다?

gamming200 572

2023년 9월 4일 3:09 오전

목록으로