점프 투 플라스크 2-04

flask db migrate를 입력한 뒤 리비전 파일도 생성된것 같은데 flask db upgrade를 입력하면 pybo.db가 생성이 되야 하는데 생성이 되질 않습니다
c:\venvs\myproject\lib\site-packages\flask_sqlalchemy__init__.py:851: UserWarning: Neither SQLALCHEMY_DATABASE_URI nor SQLALCHEMY_BINDS is set. Defaulting SQLALCHEMY_DATABASE_URI to "sqlite:///:memory:".
warnings.warn(
c:\venvs\myproject\lib\site-packages\flask_sqlalchemy__init__.py:872: FSADeprecationWarning: SQLALCHEMY_TRACK_MODIFICATIONS adds significant overhead and will be disabled by default in the future. Set it to True or False to suppress this warning.
warnings.warn(FSADeprecationWarning(
INFO [alembic.runtime.migration] Context impl SQLiteImpl.
INFO [alembic.runtime.migration] Will assume non-transactional DDL.
INFO [alembic.runtime.migration] Running upgrade -> a69b889f7944, empty message

ldy51001 83

2021년 7월 30일 2:10 오후

목록으로
1개의 답변이 있습니다. 1 / 1 Page

2-04 에서 작성한 config.py 파일이 적용이 안된것 같습니다.

app.config.from_object(config) 이 코드에 누락되지 않았는지 확인해 보세요.

박응용

2021년 7월 30일 2:43 오후

+1 위에 알려주신 코드도 __init__.py create_app 함수 안에 이 코드가 적혀 있는데 무슨 문제 일까요 ㅠㅠ --수정-- 알려주신 대로 해보고 폴더를 자세히 봤는데 config.py 파일이 pybo 안에 있어 설정이 안되었던 거였네요.... 답변 해주셔서 감사합니다~~ - ldy51001님, M 2021년 7월 30일 3:39 오후 추천 , 대댓글